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1. The Feature list 
Current Features 
1. Support Warp function, the max grid size is 65x33 

a. Linear Mode 
b. Curve Mode 

2. Edge blending with gamma adjustment 
3. Warp/Blend flash writing 
4. Test Pattern 
5. Support Stack Mode 
6. Multiple Masking 
7. Black Level 
8. HSG Adjustment 
9. Hotspot control 
10. Color Uniformity adjustment 
11. Open Project file from projector with the configuration of multi projector system 
12. Enrich the Hotkey control items 
13. Add black level coloring by eyedropper mode 

 
2. Getting started  

I. Onboarding Screen 
Double click the shortcut icon on the desktop to the tool. If you are using the software for the first time, it 
displays a series of onboarding screens, giving you a visualized explanation on how to use the software and 
what you can do with it. The onboarding screens are skipped after being used once, and you can get it from 
File > Help > Onboarding Screen. 

 
On Boarding Screen 
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II. Keyboard shortcuts  
This tool is preset with a series of keyboard shortcuts that provide a quick and efficient way to perform an  

 action. You can find the shortcut information at File > Help > Keyboard Shortcuts.  
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III. License Procedure 
Start the projector licensing to get the authority for valid use of Visual Suite functions.  
Following steps to activate the license in projectors, make reference to below procedure. 

1. Set License at Front Page to start the projector licensing. 
2. The license dialog would automatically searches for the projectors in the same network. This may take 

few seconds. User can add a projector which not found in projector searching list manually; type in the 
IP address and click ADD. 

3. Pick up the projectors and click REQUIRE LICENSE for getting the projector and exist license 
information to complete the procedure of license activation 

4. Click UPLOAD LICENSE to load the valid license files to activate the special function of Visual Suite to 
access to projectors.  

5. It is successful to activate the license when projector shows activated and License Level in list. 

 
  

License 
Generator
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IV. Welcome Page to start the project 
Welcome page to help user start a blending project or apply an existing configuration to the project. The 
button displayed below will take you to the settings flow when clicked. 

1. Creating a new file  
After the onboarding screens, the tool redirects to the welcome page, from where you can create a 

 new file or open a previous configuration file. The page also provides a list of recent files. Check the 
 installation position of your projectors, and complete following steps to create a new file. 

 
2. Open pre-existent configuration file from PC 

User can save the settings as a configuration file on the computer. By loading the file, the saved settings 
 are applied to the matching projectors.  

3. Open configuration file from Projector  
The system configuration file is saved to projectors when the setting is done. By loading the file, the 

 saved settings are applied to the matching projectors.  
 

Note: Before loading the file, make sure the required projectors are connected to the same network with the 
tool. 

Complete following steps to open a file from the computer.  
1. On the welcome page, click OPEN-PC and select a file from the pop-up windows dialog.  
2. The tool starts searching for the projectors required by the file.  
3. If the application finds all matching projectors, it applies the saved settings to the projectors and  

redirects to the main workspace 
4. When the application could not find all required projectors, it redirects to the welcome page.  
5. Check the projector connection and try again. If the file still fails to load, create a new file instead. 

V. Workspace basics  
Learn about the basics of the main workspace and shortcuts of tool.  

Main workspace  
This tool is designed with an intuitionistic and user-friendly interface, allowing the user to effectively perform 
advanced geometric adjustments on the projected images.   

The welcome page 

Create a New file for 
manual blending 

Open a file 
from PC Recent files 

Clear History 

Open a file from 
Projector 
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No. Function Description 

1 

File 
- New 
- Open 
- Projector Memory 
- Save 
- Save as 
- Reset All 
- Language 
- Log File 
- Help 
 
- Quit 

The file menu contains commands relating to the handling of files. 
Create a new configuration file. 
Load the saved file or configuration from Projector. 
Memory location selection. 
Save the settings to the current file. 
Save the settings as a new file. 
Reset all setting. 
Language selection, English/Simplified Chinese/Traditional Chinese 
Save the log file. 
Provide information of software version, keyboard shortcuts and Onboarding screen 
and. 
Exit the application 

2 Save Save the settings to the current file. 
3 Preview Project an image to view the result of current adjustments. 
4 Background Color Set the screen background to black or white 

5 Test Pattern Lines 

Set up the grid test pattern. 
 - Select 0 to disable the test pattern 
 - Set the number of test pattern lines to 5x5, 10x10 or 20x20. 
 - Select ALIGN to align the lines with the grid points. 
 - Select Contour to draw lines on the projection contour. 

6 Line Color Select a color for the test pattern lines. 

7 Apply Setting 

Function enable and auto apply for all projectors. 
 - Warp 
 - Blend 
 - Black Level 
 - Mask 
 - Hotspot Reduction 

8 Lock Mouse Lock the operation via mouse 
9 Remote Control Projector Control Items as remote control operation 

10 Function tabs Select a function of image adjustment. 
11 Layer Provide a list of projectors shown on the canvas 
12 Fit Click the button to return the canvas to its original size. 
13 Zoom in/out Click + to zoom in the canvas, and click - to zoom out. 
14 Canvas An editing area to perform image adjustments. 

Main workspace 

 1 2 3 4 5 6 7 8 9 10 

11 12 13 14 
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Click on one of the layout frame to select a projector, and the selected frame turns to 
light pink. 

 



Warp and Blend Tool Introduction 

 - 8 - 

VI. Setting up the grouping of projectors 
The setting goes to the SELECT PROJECTOR page, the list includes the projectors with valid license.  

 
1. On the welcome page, click NEW.  
2. On the projector list, select the grouping projectors.  
3. The Tool automatically searches for the projectors in the same network. This may take few seconds.  
4. To locate a projector, click the Identify button  to project a white test pattern. Click the button again to 

turn off the test pattern.  

5. In the Filename field, type in the project filename and memory location. The file is saved automatically to the 
default folder of the software.  

6. Click File > Save As button in top toolbar to save the file to specified folder. 

 
 
 

Configuration 
file Information 

Projector list 

Projector Grouping 

 Identify 
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3. Setting the Scenario and Layout: GENERAL 
The setting goes to SELECT SURFACE page, Select GENERAL surface. 

 
1. The software supports diverse scenario with different layout, general wallpaper, surround (cylinder) and 

cave. 

2. Set the numbers of Height, Width and Stack in layout setting fields. The total number of layout projectors 
must match with the number of grouping projectors. 

3. Click NEXT for the projector mapping. 
 

Scenario Setting 

Surface 
Mode 

Layout 
Setting 
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Projectors Mapping 
The setting goes to PROJECTION LAYOUT page. 

 
1. Click one of the layout frames to select a projector from pop-up projector list for layout mapping. 
2. Select a projector, and click OK.  

 
3. Repeat step a. and b. to select a projector for each layout frame. Make sure that the layout of the 

projectors are matching with the actual projection position.  

4. Click DONE to complete the projector mapping; the step is not able to return, unless redo the previous 
steps. 

 
 

  

Layout 
Frame 

Projector Mapping 

Identify Projector 
Selection 

Position 
Selection 
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4. Setting the Scenario and Layout: CYLINDRICAL 
The setting goes to SELECT SURFACE page, Select CYLINDRICAL surface for surround blending application. 

 
1. The software supports diverse scenario with different layout, general wallpaper, surround (cylinder) and 

cave. 

2. Set the numbers of Height, Width in layout setting fields. The total number of layout projectors must 
match with the number of grouping projectors. 

3. Click NEXT for the projector mapping. 
 

Scenario Setting 

Surface 
Mode 

Layout 
Setting 
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Projectors Mapping 
The setting goes to PROJECTION LAYOUT page, at Cylindrical scenario, only support 1xN layout. 

 
1. Click one of the layout frames to select a projector from pop-up projector list for layout mapping. 
2. Select a projector, and click OK.  

 
3. Repeat step a. and b. to select a projector for each layout frame. Make sure that the layout of the 

projectors are matching with the actual projection position.  

4. Click DONE to complete the projector mapping; the step is not able to return, unless redo the previous 
steps. 

 
 

1. Click one of the layout frames to select a display port from graphic card port list for port mapping to 
image cropping area. 

Layout 
Frame 

Projector Mapping 

Identify 
Projector 
Selection 

Position 
Selection 
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5. Setting the Scenario and Layout: CAVE 
The setting goes to SELECT SURFACE page, Select CAVE surface. 

 
1. The software supports diverse scenario with different layout, general wallpaper, surround (cylinder), cave 

and custom (irregular layout). 

2. Set the each side number in layout setting fields. The total number of layout projectors must match with 
the number of grouping projectors. 

3. Click NEXT for the projector mapping. 
 

Scenario Setting 

Surface 
Mode 

Layout 
Setting 
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Projectors Mapping 
The setting goes to PROJECTION LAYOUT page, at CAVE scenario. 

 
1. Click one of the layout frames to select a projector from pop-up projector list for layout mapping. 
2. Select a projector, and click OK.  

 
3. Repeat step a. and b. to select a projector for each layout frame. Make sure that the layout of the 

projectors are matching with the actual projection position.  

4. Click DONE to complete the projector mapping; the step is not able to return, unless redo the previous 
steps. 

 
  

Layout 
Frame 

Projector Mapping 

Identify 
Projector 
Selection 

Position 
Selection 
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6. Adjusting the images  
This tool offers three ways to adjust the images - warping, blending, masking, black level and HSG. To switch 
between the functions, use the function tabs at the right top corner of the main workspace.  

   

 
I. Warping the images  

Image warping is used to make an image look visually correct when it is projected onto a non-planar screen. 
Use the settings on the WARP page to change the image shape.  
 

 
No. Function Description 

1 
Line 

- LINEAR 
- CURVE 

Set the line warping style. 
Moving the point results in the lines changing the shape linearly. 
Moving the point causes the line shape changes in nonlinear fashion, not 
available at 2x2 grid points. 

2 Grid Point Set the number of grids on the screen.(support to 65x33) 

3 Move Pixel Set the pixel movement of the control point. 

4 Overlap Align Set the width and color of line for alignment. 

5 Out-of-Bounds 
Detection A checkbox function to avoid the point movement is too extreme. 

6 Apply Apply the warping adjustment. 

7 RESET Clear the warp settings. 

Function tabs 

WARP 

BLEND 

MASK 

COLOR SETTING BRIGHTNESS 

BLACK LEVEL COLOR UNIFORMITY 

Function tab - WARP 

1 

2 

3 

4 

6 7 

5
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Warping an image  

Complete following steps to warp an image.  
1. Choose a projector by clicking on its layout frame or choose it from the Layer tab. 
2. At the Test Pattern toolbar, select the grid test pattern on projection.  
3. At the Line field, select the line warping style from LINEAR or CURVE according to the screen type. 

 
4. At the Grid Point field, select the number of grids on the screen. Start with a minimal number of grids 

(2x2) and gradually increase the number when adjusting. If starting with a larger grid number, you will 
lost the current adjustment when trying to reduce the number.  

5. At the Test Pattern toolbar, click the ALIGN button to align the test pattern lines with the grid points.  

6. At the Move Pixel field, adjust the slider or enter a value to set the number of pixels that the selected 
point moves each time. Shortcuts: Press Ctrl + Up arrow to increase the pixels, or Ctrl + Down arrow 
to decrease the pixels.  

7. Select the points you want to move. The chosen ones turn to orange.  
8. To warp the image, click and drag the grid points to move them, or use the keyboard arrow keys.  

 

 
9. Click Preview  to see the warping of projection content, then click Preview again to return to the 

test pattern. 

Linear adjustment Curve adjustment 

Select a single point 
- Click the point or use the W, A, S, D keys to select a point 

Select all points on a line 
- Place the mouse cursor anywhere on the line, and 
press Ctrl + V to choose a vertical line, or Ctrl + H for a 
horizontal line. 

Select all points inside a region 
- Click and drag the cursor to select a region, and 
release the mouse to select all the points inside. 

Note: To make the warp easier, start with the outer area of the 
screen, and then move to the center area. As shown in the left 
image, adjust the red points first, and then move the blue ones.  
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Warping for image blending 
When performing edge blending on two adjacent images, slightly change the shape of the overlapped area 
helps align the two images more precisely. In the example below, two projectors are placed side by side, and 
warping the overlapped edges of the images helps achieve a better edge alignment.  

1. For better alignment manually, set two test patterns with the same number of grid lines, but different 
grid line color.  

2. Adjust the warp control points for grid line alignment on overlapped area.  
For example, point A of left projection is moved down to align the top line of right projection, and point B of 
right projection is moved down to align the bottom line of left projection.  
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II. Blending the images 
Edge Blending 
Image blending is an image process to merge two or more partial images to a complete image. Use the settings 
on the BLENDING page to blend the images.  

 
No. Function Description 

1 Overlap 
Information Top/Bottom/Left/Right Overlap blending width 

2 Apply Enable the blending data. 

3 Reset Reset blending width to default setting. 

Following steps to complete image blending.  
1. Click on layout frame or choose one from the Layer tab.  
2. Set the background and grid color of test pattern on toolbar as below,  

 Set the same background color to all projectors.  
 Set the same number of test pattern lines to all projectors.  

Function tab - BLEND 

1 

2 3 

Enable Blend 

Gamma 

Overlap 

Setup the blend edge 

Edit Pop-up dialog 
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 Set different line color of test pattern to adjacent projectors.  
3. Click the Edit icon on the edge that you want to apply the blending.  
4. Set the blending in pop-up dialog as below,  

 Switch on the Enable toggle button  to enable the blending effect.  
 At the Overlap field, set the overlap width for blending by image percentage or pixel value. The 

percentage and pixel value is based on the projection resolution.  
 Adjust the Gamma setting to change the inflection and gradient of gamma curve. 
 Click OK to apply the blending setting to the edge. 

5. Enable the blending effect, the selected edge is applied with a gradient effect. 
6. Click Preview  to see the blending effect on projection content, then click Preview again to 

return to the test pattern. 
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III. Masking 
Masking function allows you to mask out a part of a screen, creating a special visual effect. You can create a 
mask using the preset patterns, or use an image from external source.  

 
Note: The mask function only accepts external image in BMP/JPEG/PNG format with a color greyscale of 0 (black) 
or 255 (white).  

 
No. Function Description 

1 Enable Mask Enable the mask function. 

2 Shape Select a mask shape, Square, Circle and Triangle. 

3 Pen Tool Use pen tool to draw the mask. 

4 Load/Export Load/Export an image to mask the screen. 

5 APPLY Enable and apply mask data. 

6 RESET Clear the mask on the screen. 

Creating a new mask  
Following steps to create a new mask, 

1. Click on layout frame or choose one from the Layer tab.  
2. Set white background color to all projectors.  

3. Switch on the toggle button  to enable the mask effect.  

4. At the Shape field, select a shape to adjust the size and position for the mask on the screen. User can 
right click mouse to reverse the mask area of shape in “Invert color” or change the shapes’ layers in 
“Layer setting”.  

Function tab - MASK 

1 

2 

3 

4 

6 5 
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5. Click and drag the mask shape to move the position.  
6. Use the control point on the mask to change the size and shape.  

 Left mouse click and drag one of the adjustment point to adjust the mask shape.  
 Right mouse click to rotate the mask shape.  

 
7. Click Preview  to see the mask effect on projection, then click Preview again to return to the 

test pattern. 
Loading a mask  
Following steps to load the image file to mask the screen.  
1. Load the image file at BMP/JPEG/PNG format with a color greyscale of 0 (black) or 255 (white).  

 
Note: The mask image does not support any modification, such as position moving, resize or rotation.  
2. Click Preview  to see the mask effect on projection, then click Preview again to return to the test 

pattern. 

Invert the mask and the layer setting 

Edit the mask 

Load a mask pattern 
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IV. Hotspot Reduction  

Image blending is an image process to merge two or more partial images to a complete image. Use the settings 
on the BLENDING page to blend the images.  

 
No. Function Description 

1 Enable Enable the brightness effect 

2 Brightness Point Add the brightness point. 

3 Apply Enable and apply brightness data 

4 Reset Clear all brightness effect. 

Following steps to complete the brightness effect.  
1. Click on layout frame or choose one from the Layer tab.  

2. Click on Brightness Point  to add the brightness effect on projection. 

Preview a mask 

Function tab - BRIGHTNESS 

1 

2 

4 3 
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3. Adjust the area of brightness effect by dragging the corner control point as below,  

  

Setup the blend edge 

Edit Area 

Drag 
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V. Black Level 
The black image would be brighter on the most overlap area than the rest area. User can adjust the black level 
on the rest area to get the uniform black image, but less contrast. Please make reference to below black level 
effect. 

 

Adjusting the Black Level 

 
 

No. Function Description 

1 Pattern Enable the black level effect. 

2 Grid Point The grid points control the adjustment of black level area for better edge 
alignment of overlap area, up to 32 points for each black level area. 

Content Black Image 
Ideal 

W/O Black Level Effect 

W/ Black Level Effect 

Function tab – BLACK LEVEL 

1 
2 

3 

6 

4 

5 
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3 Move Pixel Set the pixel movement of control point. 

4 Load File Load the black level image file at bmp, png and jpg format. 

5 Eyedropper Eyedropper mode to pick up the black level color. 

6 RESET Reset the black level settings. 
rlapped area and the black border to make them look like the same with the overlapped area. 

 
Following steps to adjust the black level: 

1. Make sure that the black level adjustment is under dark field for good observation of black level 
variation. 

2. Click on layout frame or choose one from the Layer tab. Enable the Pattern of black level on projection. 
3. Select the Grid Point value. The grid points control the adjustment of black level area for edge alignment 

with adjacent overlap area, up to 32 points adjustment for each black level area. 

4. Set Move Pixel to control the movement for accurate alignment of adjacent black level area, user can 
set the value accordingly. 

Black Level Areas 

Grid Point 

Note: Start with 4 grid point number for the 
adjustment and increase the points gradually. 



Warp and Blend Tool Introduction 

 - 27 - 

5. Select adjustment areas using the control points. You can select two areas to adjust, one for the non-
overlapped area, and one for the black border.  

a. Click on the point you want to move. 
b. Drag the selected point to change its position on the canvas, or use the keyboard arrow keys.  

 
6. To adjust the black level color of the selected adjustment area, click on one of the area and adjust the 

black color in Color Picker dialog.  

7. Enter the RGB value or drag the slider to set the color of the selected area.  
8. Click OK on the Color Picker dialog to apply the value to the selected area.  
9. Repeat step 6 to 8 to adjust the color of the adjustment areas until they look like the same with the 

overlapped area. 

 

Adjust Areas 

Black Level Adjustment 

Color Picker 
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10. To adjust the black level color of the selected adjustment area, click on  to enable the 
eyedropper color palette and adjust the black color in Color Palette dialog.  

11. Enter the RGB value or pick the color from color palette to set the color of the selected area.  
12. Click OK on the Color Palette dialog to apply the value to the selected area.  
13. Repeat step 10 to 12 to adjust the color of the adjustment areas until they look like the same with the 

overlapped area. 

Color Eyedropper 
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VI. HSG Adjustment 
HSG function allow you to adjust HSG setting of the projector. 

 
 

No. Function Description 

1 Base Color Pick up a base color to adjust the color parameters. 

2 Hue/Saturation/Gain Adjust HSG value. 

3 RESET Click to reset the HSG value to default setting.  
 
  

Function tab - HSG 

1 

2 

3 
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VII. Color Uniformity 
Color uniformity is to adjust the uniformity gain of projection image to improve the uniformity performance. 

 
 

No. Function Description 

1 Pattern Pop-up the color uniformity gain control page, there are 63 (9x7) 
positions for uniformity gain control. 

2 RESET Click to reset the uniformity gain to project default setting.  
 
 
 
 
 
 

Function tab - Color Uniformity 
 

1 

2 
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Complete following steps to adjust the color uniformity: 
 

1. Switch to the Color Uniformity function tab. The test pattern automatically changes to the image of Color 
Uniformity control points. 

2. Choose one position and double click to get uniform color display. 
3. Click APPLY to set the uniformity gain to projection image. 

 


